华为交换机配置

示例设备华为s5700S-28P-LI-AC

用户视图<HUAWEI>:默认登录

系统视图[HUAWEI]:system-view

接口视图[HUAWEI-GigabitEthernetX/Y/Z]:interface gigabitethernet X/Y/Z
X/Y/Z为需要配置的接口的编号,分别对应“槽位号/子卡号/接口序号”

路由协议视图[HUAWEI-isis-1]: isis

恢复出厂设置步骤:
1、恢复出厂
<Quidway>reset saved-configuration 
Warning: The action will delete the saved configuration in the device.
The configuration will be erased to reconfigure. Continue? [Y/N]:Y
2、重启设备
<Quidway>reboot
Info: The system is now comparing the configuration, please wait.
Warning: The configuration has been modified, and it will be saved to the next startup saved-configuration file . Continue? [Y/N]:N
Info: If want to reboot with saving diagnostic information, input 'N' and then execute 'reboot save diagnostic-information'.
System will reboot! Continue?[Y/N]:Y


通过Console口首次登录设备后,对设备进行基本配置并配置通过Telnet、ssh、http远程登录的0~4号用户的级别为15级,认证方式为AAA认证。
设置设备时间、日期、时区;
<Quidway>clock timezone BJ add 08:00:00
<Quidway>clock datetime 17:28:00 2018-06-07
设置设备名称和IP地址
<Quidway>system-view
<Quidway>sysname HUAWEI
[HUAWEI]interface Vlanif 1
[HUAWEI-Vlanif1]ip address 172.20.120.50 24
[HUAWEI-Vlanif1]qui
设置Telnet用户的级别和认证方式
[HUAWEI]user-interface vty 0 4
[HUAWEI-ui-vty0-4]user privilege level 15
[HUAWEI-ui-vty0-4]authentication-mode aaa
[HUAWEI-ui-vty0-4]protocol inbound all
[HUAWEI-ui-vty0-4]aaa
[HUAWEI-aaa]local-user huawei password cipher huawei2018
[HUAWEI-aaa]local-user huawei privilege level 15
[HUAWEI-aaa]local-user huawei service-type telnet ssh http 
[HUAWEI-aaa]quit
[HUAWEI]rsa local-key-pair create
[HUAWEI]ssh user huawei authentication-type password 
[HUAWEI]ssh user huawei service-type all
[HUAWEI]telnet server enable
[HUAWEI]stelnet server enable
[HUAWEI]http server enable
[HUAWEI]quit
<HUAWEI>save      //保存配置,避免掉电或重启后配置失效;

基本的查看命令:
<HUAWEI>display clock    //显示时间、日期、时区
<HUAWEI>display ip interface brief    //查看接口上IP地址的简要信息
<HUAWEI>display user-interface        //查看用户界面的物理属性和配置
<HUAWEI>display local-user            //查看本地用户列表
<HUAWEI>display saved-configuration    //显示flash或nvram中的配置文件,即下次上电重启的配置
<HUAWEI>display current-configuration  //显示当前生效的配置
<HUAWEI>display users                  //查看当前已登录的用户信息
<HUAWEI>display tcp status             //查看当前建立的所有TCP连接情况
<HUAWEI>display ssh server status
<HUAWEI>display http server
<HUAWEI>display telnet server status
[HUAWEI]display interface Ethernet brief //查看以太网接口的简要信息,包括接口的物理状态、自协商方式、双工模式、接口速率、接口接收方向和发送方向最近一段时间的平均带宽利用率
[HUAWEI]display interface brief   //查看接口状态和配置的简要信息,包括:接口的物理状态、协议状态、接收方向最近一段时间的带宽利用率、发送方向最近一段时间的带宽利用率、接收的错误报文数和发送的错误报文数
[HUAWEI]display port-isolate group all   //查看接口隔离组的配置
[HUAWEI-Eth-Trunk1]display eth-trunk trunk-id   //检查Eth-Trunk是否创建成功,及成员接口是否正确加入
[HUAWEI-Eth-Trunk1]display trunkmembership eth-trunk 1  //查看Eth-Trunk的成员接口信息
[HUAWEI-Eth-Trunk1]display e-trunk e-trunk-id     //查看E-Trunk的信息
备份配置文件
1、直接屏幕拷贝
在命令行界面上,执行display current-configuration命令,并拷贝所有显示信息到TXT文本文件中,从而将配置文件备份到维护终端的硬盘中。
2、作为ftp服务器,开启ftp服务,远端作为ftp客户端连接并下载配置文件;
[HUAWEI]aaa
[HUAWEI-aaa]local-user huawei service-type ssh http telnet ftp
[HUAWEI-aaa]local-user huawei ftp-directory flash:
[HUAWEI]ftp server enable
3、远端开启tftpd64服务,连接远程tftp服务器上传配置文件;例如
<HUAWEI>tftp 172.20.120.98 put flash:/2018-06-08.zip test.zip

恢复配置文件
1、从存储器恢复配置文件
该步骤主要便于用户将存储在设备flash中的备份配置文件恢复成当前系统运行的配置文件。在设备正常工作时,使用如下命令。
<HUAWEI> copy flash:/backup.cfg flash:/config.cfg
2、通过TFTP恢复备份在PC上的配置文件
设备作为TFTP客户端。和通过TFTP备份配置文件中的备份步骤相同,差别仅在于在命令行界面中执行携带get参数的tftp命令,将存储在PC上的配置文件backup.cfg下载到设备的flash中
3、通过FTP恢复备份在PC上的配置文件
设备作为FTP服务器。和通过FTP备份配置文件中的备份步骤相同,差别仅在于在命令行界面中执行put命令,将存储在PC上的配置文件backup.cfg上传到设备的flash中。

 

端口隔离:同一端口隔离组的接口之间互相隔离,不同端口隔离组的接口之间不隔离。示例

配置GE0/0/1的端口隔离功能。
<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type access
[HUAWEI-GigabitEthernet0/0/1] port default vlan 10
[HUAWEI-GigabitEthernet0/0/1] port-isolate enable
[HUAWEI-GigabitEthernet0/0/1] quit

 

链路聚合(Link Aggregation)是将—组物理接口捆绑在一起作为一个逻辑接口来增加带宽的一种方法。

分类:

1、手工负载分担模式链路聚合

手工负载分担模式下,Eth-Trunk的建立、成员接口的加入完全由手工来配置。

该模式下所有活动链路都参与数据的转发,平均分担流量,因此称为负载分担模式。如果某条活动链路故障,链路聚合组自动在剩余的活动链路中平均分担流量;通常应用在对端设备不支持LACP协议的情况下。

[HUAWEI]interface Eth-Trunk 1

[HUAWEI-Eth-Trunk1]trunkport GigabitEthernet 0/0/1 to 0/0/4

[HUAWEI-Eth-Trunk1]mode manual load-balance

[HUAWEI-Eth-Trunk1]load-balance src-dst-ip

 

 

 

2、LACP模式链路聚合

LACP模式是一种利用LACP协议进行聚合参数协商、确定活动接口和非活动接口的链路聚合方式。该模式下,需手工创建Eth-Trunk,手工加入Eth-Trunk成员接口,由LACP协议协商确定活动接口和非活动接口。

LACP模式也称为M∶N模式。这种方式同时可以实现链路负载分担和链路冗余备份的双重功能。在链路聚合组中M条链路处于活动状态,这些链路负责转发数据并进行负载分担,另外N条链路处于非活动状态作为备份链路,不转发数据。当M条链路中有链路出现故障时,系统会从N条备份链路中选择优先级最高的接替出现故障的链路,并开始转发数据。

[HUAWEI]interface Eth-Trunk 1

[HUAWEI-Eth-Trunk1]trunkport GigabitEthernet 0/0/1 to 0/0/4

[HUAWEI-Eth-Trunk1]mode lacp

[HUAWEI-Eth-Trunk1]load-balance src-dst-ip

 

3、E-Trunk:支持跨设备的链路聚合

如下图所示,E-Trunk(Enhanced Trunk)应用于CE接入网络时,在CE与双PE间实现链路保护。CE分别通过一条LACP模式的Eth-Trunk与PE1、PE2相连。这两个Eth-Trunk构成一个E-Trunk,在PE1与PE2之间实现链路聚合组的备份,提高网络可靠性。

 

 

dhcp snooping配置:

全局设置

[HUAWEI]dhcp enable

[HUAWEI]dhcp snooping enable

[HUAWEI]dhcp server detect

统一设置用户侧的端口为untrusted(开启dhcp snooping功能后端口默认为untrusted模式);并设置对不信任端口收到的DHCP Reply报文丢弃告警功能,并配置告警阈值。

[HUAWEI]port-group untrusted

[HUAWEI-port-group-untrusted]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/23

[HUAWEI-port-group-untrusted]dhcp snooping enable

[HUAWEI-port-group-untrusted]dhcp snooping alarm dhcp-reply enable threshold 120

[HUAWEI-port-group-untrusted]quit

配置dhcp服务器侧的端口为trusted;

[HUAWEI]interface GigabitEthernet 0/0/2

[HUAWEI-GigabitEthernet0/0/24]dhcp snooping trusted

 

 

VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。

以太网是一种基于载波侦听多路访问/冲突检测CSMA/CD(Carrier Sense Multiple Access/Collision Detection)的共享通讯介质的数据网络通讯技术。当主机数目较多时会导致冲突严重、广播泛滥、性能显著下降甚至造成网络不可用等问题。通过交换机实现LAN(Local Area Network)互连虽然可以解决冲突(Collision)严重的问题,但仍然不能隔离广播报文。

在这种情况下出现了虚拟局域网VLAN技术,这种技术可以把一个LAN划分成多个逻辑VLAN。每个VLAN是一个广播域,VLAN内的主机间通信就和在一个LAN内一样,而VLAN间则不能直接互通,这样,广播报文就被限制在一个VLAN内。

 

 

 

本文来自投稿,不代表Linux运维部落立场,如若转载,请注明出处:http://www.178linux.com/100533

发表评论

登录后才能评论

This site uses Akismet to reduce spam. Learn how your comment data is processed.

联系我们

400-080-6560

在线咨询:点击这里给我发消息

邮件:1823388528@qq.com

工作时间:周一至周五,9:30-18:30,节假日同时也值班